Connected Intelligence - Service interruption alert
Incident Report for PowerSchool Products
Resolved
We are pleased to inform you that the systems have been fully restored and are now back to normal operations. All services are operating as expected.

We apologize for any inconvenience this may have caused and thank you for your patience and understanding during this time. If you experience any further issues, please do not hesitate to contact our support team
Posted Jul 22, 2024 - 12:40 PDT
Monitoring
Connected Intelligence has remained available following the Microsoft Global outage. All source systems have recovered and data replication is active for all products.

Currently, we are monitoring isolated latency and will update when resolved.
Posted Jul 20, 2024 - 09:45 PDT
Investigating
Connected Intelligence is being impacted by the Microsoft Global Outage. Access to Connected Intelligence and customer data remains available but several source systems are impacted causing replication latency.

We will keep the status page update as and when new information is available.
Posted Jul 19, 2024 - 05:45 PDT
This incident affected: Connected Intelligence K-12 and Connected Intelligence P20W.