Multiple Products - Users are encountering issues accessing Enrollment, PowerSchool eSchoolPlus SIS, eFinancePlus, EnrollmentExpress/Ecollect, PowerSchool SIS, Special Programs.

Incident Report for PowerSchool Products

Resolved

The reported issue has been resolved and this incident has been closed.
Posted May 29, 2026 - 09:44 PDT

Monitoring

We are continuing to monitor for any further issues.
Posted May 29, 2026 - 06:37 PDT

Investigating

We are currently investigating reports of users in the East region encountering issues accessing Enrollment, PowerSchool eSchoolPlus SIS, eFinancePlus, EnrollmentExpress/Ecollect, PowerSchool SIS, Special Programs.
Posted May 29, 2026 - 05:42 PDT
This incident affected: eFinancePlus, Enrollment, Enrollment Express/ECollect, PowerSchool eSchoolPlus SIS, PowerSchool SIS, and Special Programs.