eFinancePlus is being impacted by the Global Outage
Incident Report for PowerSchool Products
Resolved
This issue has been resolved for eFinancePlus.
Posted Jul 19, 2024 - 11:11 PDT
Update
All eFinancePlus customers should now have access to the affected systems. We will continue to monitor the situation. We will provide additional updates, if needed.
Posted Jul 19, 2024 - 08:03 PDT
Update
The root cause of the issue was a Windows CrowdStrike update. We will continue to provide updates until the issue has been fully resolved.
Posted Jul 19, 2024 - 05:58 PDT
Monitoring
eFinancePlus systems are being impacted by the Microsoft Global Outage. We will provide updates here as they become available.
Posted Jul 19, 2024 - 04:47 PDT
This incident affected: eFinancePlus.